Welkom, Gasten
Gebruikersnaam: Wachtwoord: Onthoud mij
12 jan 2019
Diverse hosters zijn van PHP 5.x.x en PHP 7.x.x automatisch overgeschakeld naar PHP 7.3.x. Als je Joomla website en de gebruikte extensies (componenten, plugins en modules) niet up-to-date zijn kan hierdoor je website niet meer werken.
Lees meer...

Onderwerp: Onbeveiligde website door sterk verouderd script?

Onbeveiligde website door sterk verouderd script? 1 jaar 8 maanden geleden #1

  • IndigoColors
  • IndigoColors's Profielfoto Onderwerp Auteur
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Berichten: 27
  • Ontvangen bedankjes 0
Hoi,

Ik kan sinds vandaag niet meer via mijn website op mijn webshop komen via deze link: www.indigocolors.nl/webshop/
Als ik op de button naar de webshop klik via www.indigocolors.nl dan krijg ik een foutmelding door dat de verbinding niet beveiligd is en ik kan ook niet meer inloggen in het beheervenster (zie
foto bijlagen wat ik nu te zien krijg).

Ik heb mijn hoster gemaild hierover en kreeg dit als antwoord:

Een "strict standards" melding (zoals op www.indigocolors.nl/webshop/ ) duidt vrijwel altijd op een heel erg verouderd script, plugin, module enz.

Zojuist heb ik even gekeken op uw account en ik zie inderdaad dat uw Joomla script sterk verouderd is en nooit is ge-update, deze is echt niet meer compatible met de huidige PHP standaard, u zult uw script dus z.s.m. moeten upgraden naar de laatste versie: eerst naar Joomla 1.5 stable, daarna naar Joomla 2.5 en daarna naar Joomla 3.

Let u er aub op dat u regelmatig (minimaal een keer per maand) de laatste patches en upgrades installeert voor uw scripts (net zoals u Windows update doet voor uw eigen PC om deze veilig te houden moet u dat ook voor uw hostingpakket en uw scripts doen), vooral de laatste tijd zijn er weer behoorlijk wat hackers actief.

Het is verder ook zeer aan te raden om geen scripts te installeren die u niet daadwerkelijk gebruikt omdat deze snel vergeten worden en dus verouderen en zo een veiligheidsrisico voor u, uw account, uw bezoekers en zelfs de hele server kunnen vormen.

NB: als u niet zo thuis bent in het installeren van scripts en MySQL databases kunt u veel scripts heel makkelijk installeren en de-installeren via uw cPanel control panel onder het "Softaculous" icoontje. Deze staan namelijk al voorgeinstalleerd op de server en in dat geval hoeft u de scripts niet zelf te uploaden en te installeren (en via Softaculous kunt u deze ook steeds up-to-date houden en upgraden naar latere versies).

Als u besluit om overnieuw te beginnen doet u dat dan in deze volgorde:

1.) Alle installaties die op uw account staan die de-installeert u via Softaculous (onder het "Softaculous" icoontje in cPanel) - voor zover van toepassing.

2.) Alle eventuele achtergebleven MySQL databases en MySQL database-users verwijdert u van uw account (onder het "MySQL" icoontje in cPanel) - voor zover van toepassing.

3.) Alle bestanden en mappen die hierna nog in de public_html map staan verwijdert u van uw account (onder het "Filemanager" icoontje in cPanel) - voor zover van toepassing.

Let op: alleen alle bestanden en mappen die in de public_html map staan kunt u deleten, alle andere root mappen (inclusief de public_html map zelf) laat u staan.

4.) Hierna kunt u de website plaatsen in de public_html map

(Eventueel kunt u in dat geval ook de huidige database laten staan en de nieuwe installatie na het installeren proberen te koppelen aan de oude database.)




Kan iemand mij misschien verder helpen met dit probleem want de mensen kunnen mijn webshop nu dus niet meer bezoeken :(
Alvast bedankt!
Bijlagen:

Gelieve Inloggen of Maak een account aan om te deelnemen aan het gesprek.

Onbeveiligde website door sterk verouderd script? 1 jaar 8 maanden geleden #2

  • Otto
  • Otto's Profielfoto
  • Offline
  • Administrator
  • Administrator
  • Er bestaan geen domme vragen
  • Berichten: 1219
  • Karma: 1
  • Ontvangen bedankjes 33
Hoi,

Je hoster heeft een PHP upgrade gedaan. Daardoor werkt je site niet meer.
Vraag hem of hij nog servers heeft die op PHP 5.3.x draaien.
Zo niet, dan is verhuizen je enige optie.
Artenweb.nl creatieve unieke Joomla en VirtueMart websites!
Vragen allen via dit Forum!
KvK: 61932647 - Voor onderscheidende Joomla sites die werken!

Gelieve Inloggen of Maak een account aan om te deelnemen aan het gesprek.

Onbeveiligde website door sterk verouderd script? 1 jaar 8 maanden geleden #3

  • IndigoColors
  • IndigoColors's Profielfoto Onderwerp Auteur
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Berichten: 27
  • Ontvangen bedankjes 0
Hoi Otto,
Bedankt voor je reactie!
Het zou flink balen zijn als dit zo is want ik heb de hosting net verlengd met een jaar en het is al betaald :(
Ik heb ze vandaag even jouw antwoord gemaild en ben nu in afwachting van hun antwoord.

Ik kreeg onderstaand antwoord vandaag van hun terug op mijn vraag of zij iets voor me konden doen zodat ik in ieder geval in het beheer gedeelte kan inloggen:

Het spijt me zeer maar hierin mogen wij u helaas niet assisteren, wij bieden helaas geen coding of software support, het is voor ons helaas eveneens niet mogelijk om uw (gedeeltelijke) website voor u te bouwen of aan te passen en/of uw scripts voor u te installeren of te debuggen daar hier veelal veel teveel tijd in gaat zitten. Onze excuses hiervoor, wij hopen echter op uw begrip. U kunt in dat geval wellicht inderdaad beter even contact opnemen met de makers van uw script of met een van de support fora voor een oplossing dan wel een installatie.

NB: als u niet zo thuis bent in het installeren van scripts en MySQL databases kunt u veel scripts heel makkelijk installeren en de-installeren via uw cPanel control panel onder het "Softaculous" icoontje. Deze staan namelijk al voorgeinstalleerd op de server en in dat geval hoeft u de scripts niet zelf te uploaden en te installeren (en via Softaculous kunt u deze ook steeds up-to-date houden, upgraden naar latere versies en desgewenst back-ups maken).

Let u er aub ook op dat u niet teveel rechten geeft aan uw mappen en bestanden, uw mappen kunt u 755 rechten geven en uw bestanden 644 (gebruik aub nooit 707, 777 of 775), de public_html map zelf moet op 750 staan. U kunt de rechten (permissies) wijzigen via o.a. Filemanager of de Legacy File Manager in cPanel. Geef uw configuratiebestanden (bijv. config.php of wp-config.php enz.) aub nooit meer rechten als 600.

Het is verder ook zeer aan te raden om geen scripts te installeren die u niet daadwerkelijk gebruikt omdat deze snel vergeten worden en dus verouderen en zo een veiligheidsrisico voor u, uw account en uw bezoekers kunnen vormen.

Als u besluit om overnieuw te beginnen doet u dat dan in deze volgorde:

1.) Alle installaties die op uw account staan die de-installeert u via Softaculous (onder het "Softaculous" icoontje in cPanel) - voor zover van toepassing.

2.) Alle eventuele achtergebleven MySQL databases en MySQL database-users verwijdert u van uw account (onder het "MySQL" icoontje in cPanel) - voor zover van toepassing.

3.) Alle bestanden en mappen die hierna nog in de public_html map staan verwijdert u van uw account (onder het "Filemanager" icoontje in cPanel) - voor zover van toepassing.

Let op: alleen alle bestanden en mappen die in de public_html map staan kunt u deleten, alle andere root mappen (inclusief de public_html map zelf) laat u staan.

4.) Hierna kunt u de website plaatsen in de public_html map of kunt u Wordpress opnieuw installeren via Softaculous (onder het "Softaculous" icoontje in cPanel), als u de installatie doet laat u het veld "submap" leeg zodat de installatie direct in de public_html map wordt gedaan en niet in een submap.

(Eventueel kunt u in dat geval ook de huidige database laten staan en de nieuwe installatie na het installeren koppelen aan de oude database.).

Gelieve Inloggen of Maak een account aan om te deelnemen aan het gesprek.

Onbeveiligde website door sterk verouderd script? 1 jaar 8 maanden geleden #4

  • IndigoColors
  • IndigoColors's Profielfoto Onderwerp Auteur
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Berichten: 27
  • Ontvangen bedankjes 0

Otto schreef : Hoi,

Je hoster heeft een PHP upgrade gedaan. Daardoor werkt je site niet meer.
Vraag hem of hij nog servers heeft die op PHP 5.3.x draaien.
Zo niet, dan is verhuizen je enige optie.


Ik had al gereageerd op je bericht maar heb je voor mij, in het ergste geval dat ik moet verhuizen, een tip voor een hoster die nog draait op PHP 5.3x?

Gelieve Inloggen of Maak een account aan om te deelnemen aan het gesprek.

Onbeveiligde website door sterk verouderd script? 1 jaar 8 maanden geleden #5

  • Ron
  • Ron's Profielfoto
  • Offline
  • Administrator
  • Administrator
  • Berichten: 2044
  • Karma: 1
  • Ontvangen bedankjes 42
Misschien is www.vimexx.nl/ wat voor je zeer goeie joomla hosting en niet duur!

Alleen moet je vragen of je wel een lagere PHP versie kan gebruiken!

Groeten Ron
Bent u opzoek naar een een Hotel in Sauerland voor uw motor, Fiets en wandelvakantie dan zit u bij Hotel Landgasthof Grevenstein op het juiste adres!
Handelsregister-Nr: HRA6354 Amtsgericht: Arnsberg
De volgende gebruiker (s) zei dank u: IndigoColors

Gelieve Inloggen of Maak een account aan om te deelnemen aan het gesprek.

Onbeveiligde website door sterk verouderd script? 1 jaar 8 maanden geleden #6

  • Leen
  • Leen's Profielfoto
  • Offline
  • Administrator
  • Administrator
  • Geen zorgen voor de dag van morgen
  • Berichten: 3781
  • Karma: 2
  • Ontvangen bedankjes 80
Hallo ,
Ik denk dat je als je nog bij budgetwebhosting.nl zit dat het wel moet kunnen verlagen
ik dacht te dat je dan even in cpaneel ergen beneden kan kijken welke php versie je wilt
M.v.g Leen
Bijlagen:

Gelieve Inloggen of Maak een account aan om te deelnemen aan het gesprek.

Tijd voor maken pagina: 1.877 seconden
Gemaakt door Kunena
logo mijnjoomlaforum colored puzzle2

MijnJoomlaForum.nl is niet verbonden aan en is geen onderdeel van Open Source Matters, Inc, of het Joomla! project!

Hosted by Otto
Webdesign by Renata
Sitemap

Donatie Knop